QuickBooks 2015 - requirements

What You Need on Your Computer to Run Quickbooks Premier 2015

The following are the minimum system requirements for using Quickbooks 2015 on your computer.

Operating systems supported:

    • Windows 10, all editions including 64-bit, natively installed
    • Windows 8, all editions including 64-bit, natively installed
    • Windows 7, all editions including 64-bit, natively installed
    • Windows Vista (SP1 or later), all editions including 64-bit, natively installed
    • Windows Server 2012, Windows Small Business Server 2011, Small Business Server 2008
    • Windows Server 2008 R2, Windows Server 2008, and Windows Server 2003 (SP2), including 64-bit, natively installed

Database Servers:

    • Windows: natively installed & Windows 8, Windows 7 or Vista (SP1) with UAC on, Windows Server 2011, Windows Server 2008 R2, Windows Server 2008, Windows Server 2008 – Terminal Server Config., Windows Server 2003 (SP2), and Windows Small Business Server 2008Note: Windows Home Server Edition is not supported.

Do NOT follow this link or you will be banned from the site!